1

When launching Parity UI with --unlock and --password

I get this error

No valid password to unlock account 0x00e4…fb21. Make sure valid password is present in files passed using --password or in the configuration file.

Ive created the password file with one line and password only. I've also tried creating a config file and placing it in the correct directory. I'm using parity version 2.1.3-20181015 on windows 10.

1

You're using those options correctly, but the issue here is that Parity UI has been unmaintained for a while now.

Every parity version since 2.0.0 doesn't support the UI anymore, and hence most functionality is likely broken.

the UI github page mentions some alternatives you can use instead of the UI if you really need a GUI. Otherwise you can pass the same flags to the parity binary and have your account unlocked for rpc calls.

  • Alright I tried it with the new version using this command parity.exe --unlock 0x00e4f5F746242E4d115bD65aaC7C08fE5D38FB21 --password mypassword.txt Still get the same error. – Dan Pittman Dec 11 '18 at 22:33
  • What format is your password file in (obviously, don't share the contents of the file) and do you have any success passing an absolute path to the file instead of just the filename? – Joshua Mir Dec 14 '18 at 9:43
  • Hi Joshua, I'm just using the password inside the file thats it nothing else written in it. I've also used the absolute path with no luck – Dan Pittman Dec 18 '18 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.