1

I'm getting these errors while executing

npm install web3  

How could i fix this?

the error output1

the error output2

2

Your version of Python does not match the required version for one of the dependencies. To explain your error in more detail, Python is not compiled, so version mismatch is found at run-time. The program is using the old Python 2.7 print syntax which is flagging the error. By installing the appropriate version of Python 2.7 or upgrading to a version of the library that uses an older version of Python (if there is one), you should be able to resolve this problem.

From the node-gyp README at https://github.com/nodejs/node-gyp:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.