0

I am using eth.sign from Ethereum wallet developer terminal and getting following error rejection Error: Returned Error: The method eth_sign does not exist/is not available

Please advise whats the problem. have tried everything (etc. swapping the arguments etc.)

  • Hi there. What options did you pass to your Geth instance when you started it? – Richard Horrocks Dec 4 '18 at 13:37
  • I did not use geth terminal, I m using console from Ethereum walllet developer tools – Tabz Dec 4 '18 at 14:13
0

I have solved this problem by using web3.eth.accounts.sign instead only pain I had to face to extract private key out of mist wallet

0

Method web3.eth.sign signs message on remove, i.e. node, side using private key stored by the node. This method does not work with Infura, because Infura nodes do not store any private keys.

You probably need to sign message locally on client side using web3.eth.accounts.sign, but in this case you will need to provide private key to be used for signing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.