I have tried to create bootnode by using the following command, but I cannot start the node. bootnode -genkey boot.key

bootnode -nodekey boot.key -verbosity 9 -addr :30310
INFO [11-20|18:06:05.376] New local node record   seq=1 
id=14a0c68dfe9d6ca2 ip=<nil> udp=0 tcp=0

I know how to get the enode, and I had tried to enter it directly. it does not work as well.

geth -bootnodes "enode://3ec4fef2d726c2c01f16f0a0030f15dd5a81e274067af2b2157cafbf76aa79fa9c0be52c6664e80cc5b08162ede53279bd70ee10d024fe86613b0b09e1106c40@[::]:30310"

Had spent more than 2 days. Any help will be appreciated!

4 Answers 4


You may produce the enode from nodekey by using option of --writeaddress

Refer to how to produce enode from node key?

  • Hello: Thank you for the reply. I have tried this, but it does not work. I directly enter it into the geth -bootnodes command, but it does not give me the correct p2p network. When I check it, its p2p enode is different from what I entered. Don't know why... Commented Dec 2, 2018 at 17:48

Try to -writeaddress

Example: bootnode -nodekey boot.key -verbosity 9 -addr :30310 -writeaddress

Maybe it help you

  • Thanks, I tried to use it, but it only prints the "73de589f2a9a09b59c1f6b0b3518d6cf66740c2de6aca113ebf057278686263dcdd291bff46fb7225f5fcba3afb680fe8023b8b66b8975763c4f1f0e85321405". I don't know why it is not activated. Thank you! Commented Nov 26, 2018 at 17:22
  • Did you find the answer? I have same issure
    – Alm
    Commented Nov 27, 2018 at 11:29
  • I feel like no one really understands the situation that we are facing... Commented Nov 28, 2018 at 6:29

the same to you. I think this is because your private net have not public net ip.


Replace [::] with the IP of the bootnode in geth -bootnodes "enode://3ec4fef2d726c2c01f16f0a0030f15dd5a81e274067af2b2157cafbf76aa79fa9c0be52c6664e80cc5b08162ede53279bd70ee10d024fe86613b0b09e1106c40@[::]:30310" and it should work.

( if you're running them on the same host or different IP if you're running on a different host)


geth -bootnodes "enode://3ec4fef2d726c2c01f16f0a0030f15dd5a81e274067af2b2157cafbf76aa79fa9c0be52c6664e80cc5b08162ede53279bd70ee10d024fe86613b0b09e1106c40@"

or if the IP of the machine running the bootnode is

geth -bootnodes "enode://3ec4fef2d726c2c01f16f0a0030f15dd5a81e274067af2b2157cafbf76aa79fa9c0be52c6664e80cc5b08162ede53279bd70ee10d024fe86613b0b09e1106c40@"
  • @Steve Hrimatas Make sure you remove any existing Ethereum data directory (usually /root/.ethereum) for the node (light/ full/ miner) that you're trying to fire up. I had faced the same issue. Usually, such config changes won't take effect if the node already has existing data. Let me know if this helps. Commented Nov 12, 2019 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.