3

The solidity version 0.5.0 at v0.5.0+commit.1d4f565a seems some issue while verifying at Etherscan.io

The contract I deployed: https://rinkeby.etherscan.io/address/0x0ebeb14d4af5459a74c845e56947a37a9143cba0#code

Is compiling well in remix, but exact same parameters used in verifying at etherscan, and it is not verifying.

So, is there any issue in solidity 0.5.0 ?

1 Answer 1

1

Although etherscan says, "If contract compiled at remix, will compile here", but it seems there is an issue in solidity compiler version 0.5.0 at etherscan.

I verified many contracts using previous version older than 0.5.0, but when I tried to verify a simple contract using compiler version 0.5.0, then it did not generated byte code. Even though the same contract compiled in remix.

I searched for more information, but could not find it. So, just be patient. And it will be resolved after some time.

4
  • 1
    Ok lets wait till it fix
    – Adhik
    Nov 24, 2018 at 5:41
  • If you find a bug, you should consider reporting it to etherscan. It won't get fixed if they don't know it exists Nov 24, 2018 at 15:36
  • Yes sent them bug report.. Thanks for the comment and lets see if that fix before 0.5.1 haha Nov 25, 2018 at 6:02
  • They fixed it.. Etherscan team is awesome.. It is working now.. rinkeby.etherscan.io/address/… Nov 27, 2018 at 4:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.