1

I have generated the enode from Bootnode in Ethereum private network and i connected three individual nodes using that enode through Bootnode, and i have checked whether that nodes are connected or not with my current node using the command "admin.peers". Screenshot1 those three nodes are conected successfully

then i start the mining using the command miner.start() Geth not started Screenshot2 As of my observations i am getting the line constantly, Line => "Regenerated local transaction journal transactions=0 accounts=0" for every one hour as we can see in the above screenshot But even single block is not created

Question : Why is mining not started, How to start mining? please give me some suggestions and guide me if i am wrong

I have created simple genesis.json file. Please find below

{
"config": {
    "chainId": 1015
},
"difficulty": "0x400",
"gasLimit": "0x8000000",
"alloc": {
    "ef2df6e0a312875ca7e35d8d3579cf66df558193": {
        "balance": "30000000000000000000000000000"
    }}}
  • Is it a POW? are you creating transactions? are they reaching the node properly? – Enrique Alcazar Nov 23 '18 at 14:33
  • It is not POW but it is permissioned or private blockchain based on Proof-of-Authority. It is different consensus protocols than Proof Of Work(POW). Here I am trying to connect peer to peer network and need to transactions using Ethereum private blockchain. Like i mentioned above i connected three nodes using boot node. They connected. But When I am trying to start mining for ether to do transactions. Mining is not starting. I added genesis.json file also to my question. please help – Sabareesh Nov 26 '18 at 5:57
  • Have you tried restarting it? – Aniket Nov 26 '18 at 6:37
  • yes i have restarted several times but issue was not solved – Sabareesh Nov 26 '18 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.