0

enter image description here

My smart contract could not deploy successfully, it contain 400 line. My truffle.js was configure to

module.exports = {
     // See <http://truffleframework.com/docs/advanced/configuration>
     // to customize your Truffle configuration!
     networks: {
          ganache: {
               host: "localhost",
               port: 7545,
               network_id: "*" // Match any network id
          },
          devops:{
            host:"localhost",
            port:8545,
            network_id:"4224",
            gas: 4700000        }
     }
};

But my smart contract is successful deploy in ganache but when comes to private blockchain it had error. May i know any limit size of smart contract to allow deploy to private blockchain?? and what is the way to check my size of my smart contract did it exceed the limit??

  • Please check the logs of your Geth node ( or parity ) if you didn't specify a log file check out these docs for Geth. after that post the logs related to the transaction of smart contract creation. – Kaki Master Of Time Nov 11 '18 at 19:09
  • 1
    Also, please specify which private blockchain you are talking about ? – Kaki Master Of Time Nov 11 '18 at 19:10
  • It is possible the contructor is failing and that causes the revert. Is your private testnet enabled with bizantinum opcodes? – Ismael Nov 11 '18 at 20:48
  • my smart contract is deployed to private ethereum blockchain,which is using geth – user43813 Nov 12 '18 at 2:56
0

Sometimes it causes by truffle without real problem with contract or configuration, usually removing build directory solves the issue.

  • i will try and see – user43813 Nov 12 '18 at 2:57
  • tried cannot >< – user43813 Nov 13 '18 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.