2

I am new to MetaMask, and learning how MetaMask works. I found MetaMask UI was implemented with React, so I tried to use React Dev Tool, but I am not able get it working. Please help.

  1. I started stand alone react dev tool (https://github.com/facebook/react-devtools/blob/master/packages/react-devtools/README.md)
  2. I added a line <script src="http://localhost:8097"></script> in app/home.html
  3. I used npm start to have it built in dist directory
  4. I used Chrome Extension (developer mode) to load that directory.
  5. I am seeing in Chrome console: Refused to load the script 'http://localhost:8097/' because it violates the following Content Security Policy directive: "script-src 'self' blob: filesystem: chrome-extension-resource:".

I tried to manipulate app/Manifest.json, but failed to make it work. I tried dozens of time on different combinations of "content_security_policy", and some time the React Dev Tool worked, but the MetaMask stuck at initial loading screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.