1

I am trying to use ethminer in combination with Geth to solo mine with GPU, but ethminer fails to get work.

Here is how I do. Geth is running in full sync mode and seems to be properly synchronized as I can check recent balances and the last block indicated by geth follows closely the one given by https://ethstats.net/. The geth command is:

geth --syncmode full --rpc

In addition, when launching geth, the log indicates it runs a server at http://127.0.0.1:8545/.

Then, I start ethminer (version 0.16.1) with:

ethminer -U -P http://127.0.0.1:8545

This does not work as shown by what ethminer displays:

 m 17:31:21 ethminer ethminer 0.16.1
 m 17:31:21 ethminer Build: linux/release
cu 17:31:21 ethminer Using grid size: 8,192, block size: 128
 i 17:31:21 ethminer Configured pool 127.0.0.1:8545
 i 17:31:21 main     Selected pool 127.0.0.1:8545
 i 17:31:21 main     Established connection with 127.0.0.1:8545 at 
 i 17:31:21 main     Spinning up miners...
 i 17:31:21 cuda-0   No work. Pause for 3 s.
 X 17:31:21 getwork  Failed getting work!
 i 17:31:21 main     Disconnected from 127.0.0.1
 i 17:31:22 main     Selected pool 127.0.0.1:8545
 i 17:31:22 main     Established connection with 127.0.0.1:8545 at 
 X 17:31:22 main     Failed getting work!
 i 17:31:22 main     Disconnected from 127.0.0.1
 i 17:31:23 main     Selected pool 127.0.0.1:8545
 i 17:31:23 main     Established connection with 127.0.0.1:8545 at 
 X 17:31:23 main     Failed getting work!
 i 17:31:23 main     Disconnected from 127.0.0.1
 i 17:31:24 cuda-0   No work. Pause for 3 s.
 i 17:31:24 main     Suspend mining due connection change...
 i 17:31:24 main     Selected pool 127.0.0.1:8545
 i 17:31:24 main     Established connection with 127.0.0.1:8545 at 
 X 17:31:24 main     Failed getting work!
 i 17:31:24 main     Disconnected from 127.0.0.1
 i 17:31:25 main     Selected pool 127.0.0.1:8545
 i 17:31:25 main     Established connection with 127.0.0.1:8545 at 
 X 17:31:25 main     Failed getting work!
 i 17:31:25 main     Disconnected from 127.0.0.1

Any idea of what I am doing wrong?

  • I don't think your node is synced. What does the rpc call eth.syncing return? – DaveIdito Oct 23 '18 at 15:57
  • Being able to get balance and 'latest' blocks is not a guarantee that the node is finished syncing. – DaveIdito Oct 23 '18 at 15:59
  • eth.syncing returns false. – mimo Oct 23 '18 at 16:04
  • Take a look at github.com/ethereum-mining/ethminer/issues/536 – DaveIdito Oct 23 '18 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.