1

I am trying to install "truffle-hdwallet-provider" using the command "npm i truffle-hdwallet-provider --save".

I am getting the beow mentioned error. Please assist me in resolving this.

truffle-hdwallet-provider@0.0.6 requires a peer of truffle@4.x but none is installed

enter image description here

Version details: NPM - 5.6.0 NODE - v8.11.3

  • Well there are a number of things you can try such as updating or downgrading your version of node, updating windows build tools because that is what node-gvp uses? Additionally, please include your node and npm version as that might be version specific. – GrandFleet Oct 22 '18 at 4:26
  • Version details: NPM - 5.6.0 NODE - v8.11.3 – iappmaker Oct 22 '18 at 4:29
  • I even tried updated the NPM and NODE to latest version. – iappmaker Oct 22 '18 at 5:18
  • Perhaps try installing truffle first and then truffle wallet. npm install truffle – GrandFleet Oct 22 '18 at 15:00
  • The problems is that scrypt (a dependency of truffle) fails to install. From the error message the compiler is not correctly configured. Make sure to follow this github.com/nodejs/node-gyp#on-windows when setting up the compiler. – Ismael Oct 24 '18 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.