0

The question from the title kind of wraps around the real problem but it is actually what I'm having trouble making work. I'm trying to setup production PoA network so using all the flags made for development purpose will not work for me.

The exact problem I'm having is described in this question with zero answers. Once I try truffle deploy it hangs forever. I've tried setting up local network step by step fallowing this tutorial from official parity wiki and also tried this pre-setuped docker-compose solution and it behaves the same. I kind of understand that there is (or was) something called Trusted Signer but I don't understand where it fits in Parity operated ecosystem...is it on node, separate entity or whatever it is? I noticed it is referenced together with parity-ui which has been abandoned by parity team. Clarification on trusted signer topic would be much appreciated!

I kind of narrowed down this problem to the JSON RPC function truffle uses when deploying. It uses eth_sendTransaction which creates the problem. When I copy the whole RPC call and use personal_sendTransaction and provide password as last parameter, transaction is mined.

Sorry for the block of text, hope someone knows how to solve this, if it's even possible.

So is there a way, node configuration or something, to make this work?

  • Did you make sure to unlock the account using the --unlock switch when you started the node? – Shawn Tabrizi Oct 11 '18 at 23:15
  • Think I tried that (can't remember, tried bunch of things) but it will not work for me since I need this to work with wallet providers, distribution network, not just development environment. – KwahuNashoba Oct 13 '18 at 7:58
  • What is your configuration for parity and truffle? What versions are you using? – Ismael Oct 14 '18 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.