While following this udemy tutorial I've managed to set up two nodes using with Clique and using puppeth. But the problem arises when I am about to launch the first node. This is the command

geth --networkid 1015 --datadir "./data" --bootnodes enode://876091d0a5577a006d458e5f8dc3eb7e46569969c3972f32a39e7cc92d35427ce7e03c11d336efa7b8d7e6b2563beb7c97b6a51ae9209b76a9b4f199b34a8787@  --port  30303 --ipcdisable --syncmode full --rpc --rpccorsdomain "*" --rpcport 8545 --unlock bc758cc69671f3bb2a4f0ab9aa3ca233d0074c0a --password password.txt --mine console

I have double checked the password.txt file and it exists in the specified directory. I am even running the command in the node1 directory which contains the file but I get the following error.

Fatal: Failed to unlock account bc758cc69671f3bb2a4f0ab9aa3ca233d0074c0a (no key for given address or file)

I have written the correct password in the file but somehow it is not getting it. What do I do?

EDIT: I tried what was suggested in this question too but it did not help.

Full stacktrace

INFO [10-09|15:07:05.770] Maximum peer count                       ETH=25 LES=0 total=25
INFO [10-09|15:07:05.785] Starting peer-to-peer node               instance=Geth/v1.8.15-stable-89451f7c/windows-amd64/go1.10.3
INFO [10-09|15:07:05.790] Allocated cache and file handles         database="E:\\Blockchain first step\\Private Network2\\usingpoa\\node1\\data\\geth\\chaindata" cache=768 handles=1024
INFO [10-09|15:07:05.853] Initialised chain configuration          config="{ChainID: 1015 Homestead: 1 DAO: <nil> DAOSupport: false EIP150:
2 EIP155: 3 EIP158: 3 Byzantium: 4 Constantinople: <nil> Engine: clique}"
INFO [10-09|15:07:05.872] Initialising Ethereum protocol           versions="[63 62]" network=1015
INFO [10-09|15:07:05.878] Loaded most recent local header          number=0 hash=e4305d…8a9774 td=1
INFO [10-09|15:07:05.884] Loaded most recent local full block      number=0 hash=e4305d…8a9774 td=1
INFO [10-09|15:07:05.890] Loaded most recent local fast block      number=0 hash=e4305d…8a9774 td=1
INFO [10-09|15:07:05.896] Loaded local transaction journal         transactions=0 dropped=0
INFO [10-09|15:07:05.902] Regenerated local transaction journal    transactions=0 accounts=0
INFO [10-09|15:07:05.907] Starting P2P networking
INFO [10-09|15:07:08.060] UDP listener up                          self=enode://fe6c5b1aa37c182a0c466be231921c54a469a38163e081a85751b319ea351f385ede5ae20c6cfe4c6d742bbc592420bb5102b89d15c83eed330576951382129a@
INFO [10-09|15:07:08.079] HTTP endpoint opened                     url= cors=* vhosts=localhost
  • Does the keystore for the specified account exist on that node? – Raghav Sood Oct 9 '18 at 10:15
  • It does. It exists in node1/data/keystore while the password.txt file exists in node1 – R.D Oct 9 '18 at 10:17
  • Did you try to prefix your address with 0x? – Greg Jeanmart Oct 9 '18 at 10:20
  • @GregJeanmart Yes I did. But the same error is showing – R.D Oct 9 '18 at 10:25
  • Try an absolute path for the file then – Greg Jeanmart Oct 9 '18 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.