1

I'm trying to use the Quorum-examples/7nodes to test my contract. I followed the step on github and open a terminal to attach to node1. https://github.com/jpmorganchase/quorum-examples/tree/master/examples/7nodes

However, when I used Remix and choose Web3 Provider and enter http://localhost:22000 , but it doesn't work.

I do the same test on Web3.py and it can successfully connect.

  • Did you open remix with https:// or http:// ? – ivicaa Oct 8 '18 at 19:33
  • I test them both – hhh2012aa Oct 8 '18 at 19:56
1

Edit the raft-start.sh file and add --rpccorsdomain "*" in the PRIVATE_CONFIG for the nodes that you want to access from Remix.

  • I added this option to docker-compose file and it worked just fine. – saman.shahmohamadi Jan 22 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.