1

I'm using Mac OS High Sierra version 10.13.6

My customgenesis.json file is this.

{"config": {
"chainId": 15,
"homesteadBlock": 0,
"eip155Block": 0,
"eip158Block": 0 },"nonce": "0x0000000000000042","timestamp": "0x00","parentHash": "0x0000000000000000000000000000000000000000000000000000000000000000","extraData": "0x00","gasLimit": "0x08000000","difficulty": "0x0400", "mixhash": "0x0000000000000000000000000000000000000000000000000000000000000000","coinbase": "0xd77821c8b92e3e29bc63c8f2a94a6c6a64b28b53", "alloc": {
"0xd08658a4e33bf6ca786b9870d91ec51a0dc72e56": {"balance": "10000"} }}

After creating the customgenesis.json, I ran the following command

geth --datadir ./mychaindata init ./customgenesis.json

This created my blockchain directory. After this I ran the following command to start the private network.

geth --rpc --rpcapi="db,eth,net,web3,personal" --rpcport "8545" --rpcaddr "127.0.0.1" --rpccorsdomain "*" --datadir ./mychaindata --nodiscover --verbosity 4 --unlock 0

I even tried the following command to start the private network. And tried with and without --nodiscover flags.

geth --datadir=.\mychaindata\. --rpc --rpccorsdomain "*" --nodiscover --unlock 0 --mine

Once I attach to the pic file using a different console, and start mining using the command miner.start()

This is the debug window once I start the mining process

I also tried specifying 100 threads using miner.start(100). Ended up getting the same results.

I thought maybe the difficulty was set high and hence my CPU could not mine. So I ran `etc.getBlock("latest").This was the latest block and difficulty is set to 1024

Any help or input is appreciated, Thank you.

  • Might be related to this: ethereum.stackexchange.com/q/13756/46798. What returns eth.mining and eth.syncing in the geth console ? The problem you might face is that the mining is too slow, because your hardware isn't just powerful enough. I had actually similar problem, because I used a VM (1vCPU, 2GB RAM) for mining, which is apparently not enough. – FilipR Jan 14 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.