While following this udemy tutorial and configuring the geth client I am presented with the following problem. The instructor hasn't responded yet so I thought I should ask here.

The thing is, on invoking personal.listAccounts , the console showed his account address but in my case nothing is being shown. I'm sure I did not skip over anything and the fact that our geth versions are slightly different bothers me in the sense that a few of the commands and options used simply do not work anymore in the latest version 1.8.15

What should I do to make sure that personal.listAccounts shows my address. I already have an account created in Ropsten and Rinkeby networks using metamask. enter image description here

  • 3
    Did you call personal.newAccount() first? – Raghav Sood Sep 25 '18 at 7:13
  • 1
    Nope. He did not state that I should use that. I'm just learning this so I'm almost completely dependent on the material but that worked! After calling personal.newAccount() I had to put in a passphrase and then when i called personal.listAccounts it worked!. Thanks – R.D Sep 25 '18 at 7:17
  • 2
    It's likely that he had already created accounts in the past, so just assumed they exist. Most people have a few lying around if they're running nodes. – Raghav Sood Sep 25 '18 at 7:18

To solve this, I had to call personal.newAccount() and create a new account. Since it is my first try this was necessary. After putting in the new account password and confirming it, I then called personal.listAccounts and I could see it in the array. Thanks to @Raghav Sood

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.