I have initialized the genesis file then run that command in the console-

    geth --rpc --rpcaddr --rpcport 8549 --rpccorsdomain "*" --rpcvhosts "*" --rpcapi "network,admin,personal" --datadir /home/ethereum --networkid 8982 console  

I am running the provider in my console.

 IPC endpoint opened                      url=/home/ethereum/geth.ipc
 HTTP endpoint opened                     url=            
 cors=* vhosts=*

I have given the web3 provider endpoint as : http://localhost:8549 Remix is showing this message --

Not possible to connect to the Web3 provider. Make sure the provider is running and a connection is open (via IPC or RPC).
  • Once I faced a similar issue. Are you using https to connect with remix? (By me it worked by changing https to http) – Briomkez Sep 24 '18 at 6:46
  • no its still not working. @Briomkez – crypto S. Sep 24 '18 at 6:51
  • Are you trying to connect from the https? Try connecting from the http page. – Ismael Sep 25 '18 at 7:15
  • I am connecting from http page but now its showing error: Cannot get account list: Error: The method eth_accounts does not exist/is not available – crypto S. Sep 27 '18 at 5:23
  • I changed the port number as well – crypto S. Sep 27 '18 at 5:24

I think you are not able to connect a node from browser using remix because you have not included web3 in the rpcapi list while launching geth.

Refer the issue for more details-



You are trying to run both the geth client and the DApp client on the same port. Change the http://localhost:8549 to another port say http://localhost:8540 and run again.

Make sure the port you are changing to is unused.

If the problem still persists then try to relog into your pc and try again. Sometimes Remix tends to hold the previous values. Changing the port numbers should work.


My remix IDE is now connected to the private network. I used the following:

     geth --networkid 8982 --datadir "E:\privateEthereum\private" --rpc --rpcaddr "" --rpcport "8549" --rpcapi "web3,net,eth,admin,personal" --rpccorsdomain "*" console

The only mistake was I used network instead of net in rpcapi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.