2

Get Geth to sync --> Rinkeby test network. For the love of god I just want to deploy a contract. I have deployed it to Ganache-cli, GUI, remixIDE, deployed with truffle/Infuria.io...I keep failing to synchronize the rinkeby network. I have tried on macOS with commands geth --rinkeby --rpc --rpcapi="personal,eth,network,web3,net" --ipcpath "~/Library/Ethereum/geth.ipc"

I tried on windows, ubuntu and I had the same problem.

I will fire up geth attach and eth.syncing will show the blocks climbing and there will be maybe around 100 blocks left and then it will show an error: Synchronization failed, dropped peers etc etc. The eth blocknumber, eth latest block shows zero, wallet shows zero balance even though I transferred test eth to the account and it shows up on Ropsten/Rinkeny Etherescans.

  • I have tried no ipcpath declaration
  • Deleting the blockchain data and restarting
  • Checking the time sync
  • I have tried ropsten network syncing same problem
  • I have heard you cannot sync with a standard HDD? I don't know, is this true for test networks? Mainnet?

I am sure I am doing something wrong on my end because I have tried multiple OSs, different systems. Please any assistance would greatly be appreciated. Too many hours, my chest hurts.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Welcome to Stack Exchange! Unfortunately this appears to be an existing error with Ethereum, especially the rinkeby network. github.com/ethereum/go-ethereum/issues/14381 My recommendation would be to try restarting the node a few more times while tracking dev progress. – Devon Yarbrough Sep 25 '18 at 20:39
0

I can sync rinkeby without any problems using the following command:

geth --rinkeby --syncmode "fast" --rpc --rpcapi db,eth,net,web3,personal --cache=1024  --rpcport 8545 --rpcaddr 127.0.0.1 --rpccorsdomain "*" --allow-insecure-unlock

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.