1

I recently transferred some eth from my account to another (Kraken specifically to exchange it). That worked, then a couple days later I tried to transfer more, the geth console returned the same output (some sort of transaction id), but the other account never received it. I tried removing my ~/.ethereum folder and restarting geth to see if it was a problem with its state, but that didnt't help. Now it shows the old balance (before my first successful transaction), and I still can't transfer eth. Etherchain.org and others reflect the correct value.

Any ideas what would cause this? Here is my geth version:

Geth
Version: 1.4.6-stable
Protocol Versions: [63 62 61]
Network Id: 1
Go Version: go1.6.1
OS: linux
GOPATH=
GOROOT=/usr/lib/go-1.6
3

As 5chdn said, you have to wait till your chaindata is completely synced.

There are multiple ways you can speed up the process

  1. use geth --fast
  2. Import the chain data
  3. Copy/Paste the chain data folder.

This answer explains a lot

  • From experience, and from the answer you link to, using geth import <filename> isn't particularly fast... :( – Richard Horrocks Jun 11 '16 at 23:42
  • Is there a way to reason about the time it will take to complete? What's strange is, when I made my first transaction a few days ago, I had only run geth client for a few hours maybe, and now its been many times that but it still doesn't work. – wjimenez5271 Jun 12 '16 at 0:54
  • @wjimenez5271 eta for completion is depends upon many factors like speed of internet, you computers gnu/cpu performance no of peers connected etc. – niksmac Jun 12 '16 at 2:50
  • @RichardHorrocks yeah, i have mentioned some ways for getting sync. – niksmac Jun 12 '16 at 2:51
  • OK great, it finally completed, just took much longer than previously. This was helpful background information. Thanks – wjimenez5271 Jun 13 '16 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.