2

I have download the ethereum source from github and store the source in directory "~/EthereumSource/go-ethereum".

I have install all required software to build the source and successfully build the source from terminal using "make geth". I can run a private node using this geth.

Now I want to run the individual test files from source but failed.

Command: "~/EthereumSource/go-ethereum/p2p/testing$ go test protocoltester.go"

Error: protocoltester.go:35:2: cannot find package "github.com/ethereum/go-ethereum/log" in any of: /usr/local/go/src/github.com/ethereum/go-ethereum/log (from $GOROOT)

I have solved the problem using the following command (adding build/env.sh)

Command ~/EthereumSource/go-ethereum$ build/env.sh go test ./p2p/testing/protocoltester.go

but now i have this error "p2p/testing/protocoltester.go:48:2: undefined: ProtocolSession"

I have also tried to run a different file server_test.go but failed

Command : ~/EthereumSource/go-ethereum$ build/env.sh go test ./p2p/server_test.go

Can anyone help me to show the proper steps to build those two files?

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.