11

I keep getting an error: ethminer Failed to submit hashrate :( I am very new to this whole mining thing, and just want to learn more. I am using:

Geth
Version: 1.5.0-unstable

ethminer version 1.2.7
Build: Linux/g++/Interpreter/RelWithDebInfo

This is the error:

miner  10:16:59.788|ethminer  Mining on PoWhash #d89fc0ca… : 2759410 H/s = 1572864 hashes / 0.57 s
  ✘  10:16:59.808|ethminer  Failed to submit hashrate.
  ✘  10:16:59.808|ethminer  Dynamic exception type: jsonrpc::JsonRpcException
std::exception::what: Exception -32700 : JSON_PARSE_ERROR: The JSON-Object is not JSON-Valid:  Database Error

I've used the commands (to start mining):

./build/bin/geth --rpc --rpccorsdomain localhost

./libethereum/ethminer/ethminer -G -F http://ethereumpool.co/?miner=10@[ADDRESS]@myrig

Btw I am guessing that [ADDRESS] is my coinbase (ethereum account on geth), is that right?

Any ideas why this is happening? I am currently using the develop branch from geth and Ubuntu Xenial

4

Your client is trying to submit something to the server that's operated by the pool. Instead of returning valid json like it should; the server returns a string:

Database Error

It seems obvious to me there is nothing you can do to 'fix' this. It's a problem with the pool. All you can do is retry.

  • 1
    unfortunately this seems to be the answer :P with dwarfpool it is working – doart3 Jun 13 '16 at 10:41
3

I also had this error and complete deletion of the ethminer folders under ~/.ethash and restart of ethminer did the trick.

2

I recently dealt with the very same issue, and unfortunately there is no clear solution from just the information provided.

Some steps that may get you back on your feet:

  • Are you using an AMD card? Are you running catalyst version 16 drivers? Catalyst v16 has been known to produce bad shares and was my eventual issue. Uninstall the v16 drivers completely, reboot, then install v15 drivers.
  • Your DAG may be corrupted. Stop geth, delete your DAG file, restart geth and the miner and the DAG will be rebuilt.

Best of luck, these errors can be tricky to fix.

  • Thanks for the reply, I am using an Nvidia 745 already have deleted the DAG file :( – doart3 Jun 10 '16 at 11:50
  • @doart3 I see on the specs page for the 745 says it can have up to 4 gb of GPU RAM. How much does your 745 have? Just trying to cover all my bases. geforce.com/hardware/desktop-gpus/geforce-gtx-745-oem/… – Burke9077 Jun 10 '16 at 12:11
  • My graphics card has 4096 MB – doart3 Jun 10 '16 at 12:46
2

It appears that ethminer was broken in the 1.2.6 release.

https://github.com/ethereum/webthree-umbrella/issues/558

I am working on a 1.2.8 release today, which would address the issue.

The other alternative is to use Genoil's miner - https://github.com/Genoil/cpp-ethereum.

NEW RELEASE HERE -> https://twitter.com/BobSummerwill/status/741450414290149376

  • probably missing something but I am still getting the same error :( ./ethminer -V ethminer version 1.2.8 Build: Linux/g++/Interpreter/RelWithDebInfo – doart3 Jun 13 '16 at 10:11
  • with dwarfpool it is working though ;) – doart3 Jun 13 '16 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.