0

I need to install an old version of Swarm : version 1.7.3-stable , but I can't figure out how to install it from the command line.

I'm on Mac OSX.

I've found these old downloads: https://geth.ethereum.org/downloads/ but I can't figure out how to install them on my machine. I'd prefer to install from source, if possible.

I can only manage to install the latest versions of geth and swarm:

$geth version
Geth
Version: 1.8.14-stable
Architecture: amd64
Protocol Versions: [63 62]
Network Id: 1
Go Version: go1.10.3
Operating System: Darwin
GOPATH=/Users/me/go
GOROOT=/usr/local/Cellar/go/1.10.3/libexec

$swarm version
Swarm
Version: 0.3.2-stable
Go Version: go1.10.3
OS: Darwin

However, these latest versions aren't compatibile with the code of the project I've just joined.

The team I've joined are using Geth 1.7.3 and Swarm 1.7.3 (note that it appears Swarm version numbers used to coincide with Geth version numbers, but have since separated, as you can see with my versions above). I need to revert both Geth and Swarm back to 1.7.3 on my machine.

Is there a way to clone and install an old version from a github repo? Any help appreciated!

  • You can geth the source code for the right version here github.com/ethereum/go-ethereum/releases and then compile it. There are also the binaries, they should work too (although I am not familiar with MAC OSX) – Briomkez Sep 13 '18 at 13:04
1

you need download the source and check out with your version like 1.7.3 then compile it with proper go version like 1.9 , then you got it.

0

Old releases are available in Releases section of Ethereum's repository. Both, source code and binary distribution: https://github.com/ethereum/go-ethereum/releases

And btw, 1.7.3 is not so old, a lot of nodes are still running on 1.7.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.