0

I run a private local Parity node that uses the Ethash engine. How do I use a miner with it?

I tried ethminer like suggested in the wiki (https://wiki.parity.io/Mining), but executing ethminer -G responds with "At least one pool URL must be specified". I also tried running ethminer -F http://localhost:8545 as suggested in Parity mining in testnet, but it says The following argument was not expected: -F.

Here's my mining config section: [mining] engine_signer = "0x00bd138abd70e2f00903268f3db08f2d25677c9e" author = "0x00bd138abd70e2f00903268f3db08f2d25677c9e" And this is my chainspec engine part: "engine": { "Ethash": { "params": { "minimumDifficulty": "0x020000", "difficultyBoundDivisor": "0x400", "metropolisDifficultyIncrementDivisor": "0xA", "blockReward": "0x4563918244F40000", "homesteadTransition": "0", "difficultyHardforkTransition": "0xC55F7BC23038E38", "difficultyHardforkBoundDivisor": "0x800", "bombDefuseTransition": "0", "eip150Transition": 0, "eip160Transition": 0, "eip161abcTransition": 0, "eip161dTransition": 0, "eip170Transition": 0, "eip100bTransition":0, "eip658Transition":0 } } },

I don't care which miner I use, I just need my transactions to be mined.

1

Enabled Stratum on my node, then ethminer -G -P stratum+tcp://127.0.0.1:8008 worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.