2

May I know what does this transaction mean? I am running this inside my private node. Running the same transaction repeatedly none stop. Sending on average 10 transactions / sec. So I had to keep track of the nonce.

But suddenly the transaction below just stopped and refused to process. Query transaction receipt just return null.

May I know what might had gone wrong?

Did I skipped one nonce? How can I tell if I had really skipped one nonce?

> eth.getTransaction("0xb992cfa1e25268de903d54196c1efa1908fcaf900a304db2bde14c1315461dca")
{
  blockHash: "0x0000000000000000000000000000000000000000000000000000000000000000",
  blockNumber: null,
  from: "0xc8caa71c16299b40b8579742a27ee53162886040",
  gas: 160000,
  gasPrice: 2600000000,
  hash: "0xb992cfa1e25268de903d54196c1efa1908fcaf900a304db2bde14c1315461dca",
  input: "0x2a281eb70000000000000000000000000000000000000000000000000000000000000011",
  nonce: 2049,
  r: "0x88741393e597de552cf28563c7a601fd7c4f43111144f010d29011aac82756e9",
  s: "0x6becf956d4d622ca4cbe68381dfd6f614aa75fe6ffc6c2081dc725b79ee51819",
  to: "0x9ee0ff1b31fb2587d55f3a6726cb6d653d4b6615",
  transactionIndex: 0,
  v: "0x47",
  value: 0
}
  • 1
    What does eth.getTransactionCount("0xc8caa71c16299b40b8579742a27ee53162886040") returns? Perhaps your node skiped a nonce? – Ismael Sep 3 '18 at 17:28
  • Yes. Finally I realized what had gone wrong. The getTransactionCount returns little endian whereas Windows uses Big endian byte array. I had skipped. – s k Sep 4 '18 at 5:03
1

The eth.getTransaction() details that you have posted shows blockNumber: null.

It implies that the transaction with the transaction hash "0xb992cfa1e25268de903d54196c1efa1908fcaf900a304db2bde14c1315461dca" has not been mined into a block or you could say added into a block.

If you are using Ethereum's PoW as a consensus algorithm then it takes 15 seconds to mine a block, and as you said 10 transactions on an average, it is clear that you tried fetching details of a transaction that was not yet mined.

  • It had been there for more than 10 minutes. That is why I feel strange. This problem gone when I tried to limit the rate of transaction to more than 15sec. If I send many transactions in less than 15 sec, this problem will come back again. There might have some threading issues. – s k Sep 1 '18 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.