3

During the installation I've got at the end this:

Last 15 lines from /Users/maksim/Library/Logs/Homebrew/parity/02.multirust:

 Compiling serde v0.7.4
 Compiling itertools v0.4.13
 Compiling bytes v0.3.0
 Compiling winapi-build v0.1.1
 Compiling bloomchain v0.1.0
 error: linking with `cc` failed: exit code: 1 note: "cc" "-m64" "-L"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/target/release/build/heapsize-40dd75c58e1708a9/build_script_build.0.o"
 "-o"
 "/private/tmp/parity-20160607-9932-1o2o3fo/target/release/build/heapsize-40dd75c58e1708a9/build_script_build"
 "-Wl,-dead_strip" "-nodefaultlibs" "-L"
 "/private/tmp/parity-20160607-9932-1o2o3fo/target/release/deps" "-L"
 "/private/tmp/parity-20160607-9932-1o2o3fo/target/release/deps" "-L"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/libstd-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/libcollections-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/librustc_unicode-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/librand-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/liballoc-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/liballoc_jemalloc-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/liblibc-d16b8f0e.rlib"
 "/private/tmp/parity-20160607-9932-1o2o3fo/.brew_home/.multirust/toolchains/stable/lib/rustlib/x86_64-apple-darwin/lib/libcore-d16b8f0e.rlib"
 "-l" "System" "-l" "pthread" "-l" "c" "-l" "m" "-l" "compiler-rt"

 note: ld: entry point (start) undefined.  Usually in crt1.o for architecture x86_64
 clang: error: linker command failed with exit code 1 (use -v to see invocation)

 error: aborting due to previous error
 Build failed, waiting for other jobs to finish...
 error: Could not compile `heapsize`.

 To learn more, run the command again with --verbose.

Before I do --verbose, may be someone already can see what the problem is?

Thanks from not so much experienced Mac user!

Update: During installation according to @Ellis get the following:

maksims-mbp:parity maksim$ brew update && brew install multirust
Already up-to-date.
Warning: multirust-0.8.0 already installed
maksims-mbp:parity maksim$ multirust default stable
multirust: installing toolchain 'stable'
rustup: gpg not available. signatures will not be verified
rustup: downloading manifest for 'stable'
rustup: command failed: curl -s -f -O https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256
rustup: couldn't download checksum file 'https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256'
rustup: downloading manifest for 'stable'
rustup: command failed: curl -s -f -O https://static.rust-lang.org/dist/channel-rust-stable.sha256
rustup: couldn't download checksum file 'https://static.rust-lang.org/dist/channel-rust-stable.sha256'

Any ideas on how to fix it? Does it have something to do with "not having 'gpg' "?

  • just try: brew install gpg – Ellis Jun 20 '16 at 12:55
  • multirust: installing toolchain 'stable' rustup: gpg available. signatures will be verified rustup: downloading manifest for 'stable' rustup: command failed: curl -s -f -O https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256 rustup: couldn't download checksum file 'https://static.rust-lang.org/dist/channel-rust-stable.toml.sha256' rustup: downloading manifest for 'stable' rustup: command failed: curl -s -f -O https://static.rust-lang.org/dist/channel-rust-stable.sha256 rustup: couldn't download checksum file 'https://static.rust-lang.org/dist/channel-rust-stable.sha256' – Maksim Ravnovesov Jun 21 '16 at 10:29
  • still can't download checksum ? – Maksim Ravnovesov Jun 21 '16 at 10:30
  • just try: brew install curl – Ellis Jun 21 '16 at 12:50
  • Look in the article about ubuntu. I install many packages: file git curl bzip2 make – Ellis Jun 21 '16 at 12:51
4

I have worked on parity few weeks ago on OS X. This guide is for Parity 1.2. The build is very long. I suppose you have installed homebrew.

Homebrew (juin 2016) have a preinstalled version of Parity : version 1.1. To avoid any conflict, let's delete this one and jump on 1.2 version :

user:~ brew remove parity

Ethcore provides a unique command to install Parity, but to install version 1.2, you shouldn't use it, but rather proceed like this :

user:~ brew update && brew install multirust
user:~ multirust default stable
user:~ cd && git clone https://github.com/ethcore/parity.git && cd parity
user:~ cargo run --release
user:~ sudo cp parity//target/release/parity /usr/local/bin/

This command install the rust compiler and download all that is needed from github. After a few moment, parity is deployed on your system.

If you look for more information, you can read this article: https://ellis2323.gitbooks.io/blckchn/content/[EN]_Parity.html

  • Thanks, @Ellis. During installation have another error, I've updated the initial post. – Maksim Ravnovesov Jun 20 '16 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.