0

I think both of --network id 3 and --testnet mean to the Ropsten network.

But, The result of "eth.syncing" differ from each.

--testnet result "highestBlock: 3852529"

$ geth --testnet console 2>> geth-test.log
> eth.syncing
{
  currentBlock: 3788019,
  highestBlock: 3852529,
  knownStates: 18107905,
  pulledStates: 18107905,
  startingBlock: 3787849
}

--networkid 3 result "highestBlock: 6105050"

$ geth --networkid 3 console 2>> geth-test.log
> eth.syncing
{
  currentBlock: 1181005,
  highestBlock: 6105050,
  knownStates: 1529557,
  pulledStates: 1529557,
  startingBlock: 1181005
}

I do not know why this is the case... Are not they the same?

  • Ropsten's network ID is 3, but setting just --networkid 3 without --testnet will not put you on ropsten, apparently. – Raghav Sood Aug 17 '18 at 3:28
0

I think it's a bug in Geth and has been reported a while ago on GitHub. --networkid 3 brings to the mainnet.

If you want to connect a public test network, use

  • --testnet for Ropsten
  • --rinkeby for RinkeBy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.