1

Could you please help me to find out what I’m doing wrong. I’ve topped up my test accounts from https://faucet.rinkeby.io/. When I check their balances on https://rinkeby.etherscan.io/balancecheck-tool, I can see that both of them have 3 ethers each. The accounts are: ‘0x402596a354411c73a3fe8e99ba1e7226fe88361c’ and ‘0x6403e1c470f3bb7f0f1bd23756624e0293f98079’.

But when I open a connection with Rinkeby test network using this command: geth --rinkeby --rpc --rpcapi="personal, eth, network, web3, net" --ipcpath "~/Library/Ethereum/geth.ipc" (I left my computer for night to get all the updates from Rinkeby) and on the other tab open Geth console (geth attach) and run eth.syncing I see that my local network is updated. But when I run eth.getBalance(eth.accounts[1]) or eth.getBalance(eth.accounts[2]) to see the balances of my funded accounts I see 0.

What am I doing wrong? Could you please help me overcoming this issue? I will be so grateful to you! This problem is driving me insane...

  • 1
    What is your latest local block number? – Raghav Sood Aug 12 '18 at 7:14
  • 1
    If I run eth.getBlock("latest") is 0, if we talk about "eth.syncing" it's almost finished and above the block where my transaction happened – Alina Solinas Aug 12 '18 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.