0

I have a problem when deploying smart contracts on remix. When I click create, I can see that transactions are passing through, from the blockchain explorer. I clicked multiple times, and this is the result.

https://imgur.com/a/s6uiqsG

However, I am getting the below 'error' and the contract does not seem to be deploying. I have tried different contracts and changing browser, to no avail.

https://imgur.com/7W5mBuc

I am connecting to my node via web3 provider. I can see my wallets

enter image description here

I am adding a sample smart contract:

  contract test{

    int _multiplier;

    function test (int multiplier){
        _multiplier = multiplier;
    }

    function multiply (int val) returns (int d){
        return val * _multiplier;
    }

}

When deploying the smart contract, i can see it in geth.

enter image description here

then i get the error mentioned above in remix.

  • Where are you deploying your contract? ie mainnet or private testnet. Did you try to deploy in the "Javascript VM"? There are several causes that might prevent your contract to deploy: constructor causes an error, gas allowed is not enough. If you show us your source we can inspect the constructor for common errors. – Ismael Aug 9 '18 at 0:08
  • this is a private blockchain, i tried to deploy on VM 3 contracts, all succeeded. web3 fails – DottoreM Aug 9 '18 at 9:10
  • Does your private tesnet has a block gas limit large enough to deploy your contracts? Can you show us the transaction receipt of the failed deployment? we cannot infer much from the error message you show here. What version of the solidity compiler are you using? Does your private network enabled byzantinum opcodes? Since solc v0.4.22 the compiler generates bytecode with byzantinum opcodes if your private testnet doesn't have them enabled your contract will fail. – Ismael Aug 9 '18 at 15:59
  • In the genesis I have : "difficulty": "0x4000", "gasLimit": "0x8000000" . Please excuse my ignorance, but can you enlighten me more with the transaction receipt. I tried to get info from remix but couldnt. i managed to get a transaction receipt working with nethereum – DottoreM Aug 10 '18 at 15:21
  • Remix will show the receipt formatted when you click on the down arrow of the transaction. Can you try compiling with an older version of solidity before v0.4.22 to see if that work? – Ismael Aug 10 '18 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.