I can't seem to figure out why the function symbol() isn't working. I've made sure that MetaMask is on the right network (main net). I tried console.logging the myContract.methods... line and seem to get an error, but can't seem to figure out what it means.

console.log showing error

$( document ).ready(function() {

  var myContract;

  function startApp() {
     myContract = new web3.eth.Contract(crowdsaleABI, 

  // Checking if Web3 has been injected by the browser (Mist/MetaMask)
  if (typeof web3 !== 'undefined') {
     // Use Mist/MetaMask's provider
     web3 = new Web3(web3.currentProvider);
     document.write("You are connected to MetaMask");
  } else {
     // Handle the case where the user doesn't have web3.
     document.write("You are not connected to MetaMask");
     web3 = new Web3(new 
  // Now you can start your app & access web3js freely:

  myContract.methods.symbol().call().then((result) => 


  at A.R [as _captureStackTrace] 
  at A._then (http://localhost:3000/src/js/web3.min.js:1:373974)
  at A.then (http://localhost:3000/src/js/web3.min.js:1:372344)
  at HTMLDocument.<anonymous> 
  at i (https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js:2:27449)
  at Object.fireWith [as resolveWith] (https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js:2:28213)
  at Function.ready (https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js:2:30006)
  at HTMLDocument.K (https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js:2:30368)"*/

EDIT: I also tried replacing web3.currentProvider with an Infura API to the main net and it actually worked. So it seems to be something with MetaMask, but I still can't seem to figure out what exactly.

  • Based on your edit, my guess would be that MetaMask isn't connected to mainnet, or the fallback is being reached and isn't connected to mainnet.
    – user19510
    Jul 30 '18 at 13:41
  • I tried using MetaMask with some other DApp and it responds just normal to it.
    – dkelsen
    Jul 30 '18 at 14:09
  • Which message do you see? "You are connected to MetaMask" or "You are not connected to MetaMask"? What software is running at, and what network is it connected to?
    – user19510
    Jul 30 '18 at 14:18
  • It shows "You are connected to MetaMask". I'm running Ganache at, so it's a private network.
    – dkelsen
    Jul 30 '18 at 14:35
  • If you're seeing "You are connected to MetaMask", then the private network shouldn't matter (but you might want to remove the else block just to be safe). I'd suggest inspecting web3.currentProvider to make sure it's MetaMask and double check once again that MetaMask is connected to mainnet. (Perhaps switch to a test network and then switch back.)
    – user19510
    Jul 30 '18 at 14:40

It looks like using document.write is the problem. Switching to console.log in your repro fixes the problem for me.

I don't know why that causes a problem, but it's probably not worth spending too much time on. (document.write is considered a bad practice these days.)


I should add that I saw different behavior from you. For me, the Promise never resolved one way or the other. (then and catch handlers didn't get called at all.) Removing the document.write calls resolved this for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.