1

I've been having trouble for a day now deploying a token in Main Net using Remix. Both Kovan and Rinkeby worked well and instantly but Main net would fail without any error messages.

Now I tried deploying a simple dummy example code found in Ethereum docs:

pragma solidity ^0.4.0;

contract SimpleStorage {
    uint storedData;

    function set(uint x) public {
        storedData = x;
    }

    function get() public view returns (uint) {
        return storedData;
    }
}

Tried deploying using Remix, worked perfectly in Kovan and Rinkeby (using remix + metamask) but to my surprise, the same error occured on Main Net.

enter image description here

Remix stays frozen in this "Pending" message. Transaction address returns: "Sorry, we are unable to locate this Transaction Hash"

Tried increasing gas prices and quantity. No change.

Pulling hair out here. Wtf is going on?

  • Do you get the MetaMask popup asking you to confirm the transaction when deploying to mainnet? Presumably you see this on the Kovan / Ropsten deployments. – Adam Dossa Jul 24 '18 at 19:51
  • 1
    The problem was metamask itself, the popup appears but for Main Net won't go through, used myetherwallet and it worked. – raphadko Jul 24 '18 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.