0

I'm deploying a contract using its bytecode in wallet.ethereum.org. I deployed it on Kovan and it went very smooth and fast, fee was 1782250 gas @ 4 Gwei price.

With the exact same bytecode, I tried deploying on Main Net with higher gas than recommended by wallet.ethereum.org, my last try was with a limit of 1982250 Gas @ 4 Gwei price.

But still, processing takes a long long time and ultimately fails.

What could be going wrong?

Edit: Also tried using Remix with the contract code itself (not bytecode) and same thing happens, deploys ok on Kovan, fails on Main Net. The contract is a standard BurnableToken from OpenZeppelin.

  • Do you have a tx hash? It will tell you if it ran out of gas, or if it encountered another error. – Raghav Sood Jul 24 '18 at 5:58
  • Tx hash shows this on Etherscan: Sorry, we are unable to locate this Transaction Hash (etherscan.io/tx/…) – raphadko Jul 24 '18 at 6:05
  • In that case your tx hasn't been mined at all. You'll need to try again (or wait until this is mined by rebroadcasting it) – Raghav Sood Jul 24 '18 at 6:41
  • Did it 20 times – raphadko Jul 24 '18 at 12:29
  • Also increased limits to this: Gas 5,882,250 - Gas price 0.006 - No success – raphadko Jul 24 '18 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.