0

I've a Windows Server VM on Azure where geth is running quite good (no mining, just node).

Now, the "start command" is:

geth --rpcapi "eth,web3,db,net,personal,admin" --rpcaddr "10.0.0.4" --port "30303" --rpccorsdomain "*" --rpcport "8545" --rpc --ws --wsaddr "10.0.0.4" --nat "any"

From the Virtual Machine itself, I can go on the browser and write

 http://10.0.0.4:8545 

And everything is working. From "outside" I try to access to

http://virtualmachineip:8545

And I get a Timeout, event if the firewall rule I configured is TOTALLY permissive like:

enter image description here

What could be the problem?

Thanks

  • 2
    try with --rpcaddr "0.0.0.0" – kherwa Jul 19 '18 at 12:37
  • @kherwa most probably it will not work for Windows, it would be better to skip setting rpcaddr (default localhost) or set to 127.0.0.1 – Aquila Oct 1 '18 at 14:35
2

Go to the loadbalancer --> Inbound NAT Rules and add a New rule pointing to your VM and teh port as 8545

0

I figured out that it was not enough to "open the port" from the Web Interface. After I opened also on Windows everything worked smoothly!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.