2

I am able to connect using metamask localhost 8545 option, as well as computer within the intranet.

geth --identity "SK" --datadir data --networkid 18 console --rpc --rpcport 8545 --rpcaddr "0.0.0.0" --rpccorsdomain "*" --rpcapi "db,eth,net,web3,personal"

But I can't connection outside my NAT router.

I am very sure that I have enabled port forwarding for TCP/UDP 8545, and able to see that port externally.

May I know what might had gone wrong in my settings?

2

try to use the option :

  --nat value           NAT port mapping mechanism (any|none|upnp|pmp|extip:<IP>) (default: "any")

if your router supports upnp go for :

--nat upnp
  • 1
    extip:<IP> works – s k Jul 13 '18 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.