I'm following PetShop tutorial, and everything works fine until Metamask came to the picture.

I've restored vault using mnemonic, added RPC URLHTTP://, it displaying Private Network at top, however ether is Zero, wheres in Ganache it's 100 ETH.

enter image description here enter image description here

I've confirmed address twice, but no luck so far..Is there any work around?

  • try to lock metamask and open it again
    – TahaBA
    Jun 26 '18 at 6:28
  • Tried already, also tried with remove from Chrome and added it again, though no luck. Jun 26 '18 at 6:29
  • Check the time sync.
    – TahaBA
    Jun 26 '18 at 6:33
  • @TahaBA: Sorry, didn't get you Jun 26 '18 at 6:40
  • Check the time on you PC .
    – TahaBA
    Jun 26 '18 at 6:43

This seems funny but you have to use HTTP in a lower letter. So use instead, and it'll start displaying Ether to your account.

  • 1
    please consider to accept your own answer
    – Badr Bellaj
    Jul 13 '18 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.