0

I'm trying to deploy a contract on the mainnet, and I'm using Solidity 0.4.24

I can only deploy the contract as byte code because I can't figure out how to upgrade the solidity compiler in mist (the question is not about that).

Deploying the contract as byte code works fine on Ropsten. However, on the mainnet I tried at least 20 times and I always get 0 confirmations. I even increased the FEE slider to the maximum.

My question:

  • Does the mainnet not yet accept this version of solidity?
  • Do I have to increase the fee even more?
  • Is it because I'm deploying it as byte code directly?
  • Are you able to publish any transactions to mainnet via Mist? Try sending a few Wei to yourself. – Mikhail Vladimirov Mar 26 at 12:54
0

Somehow this solved my problem:

  • Quit MIST
  • Stop geth
  • Start geth with --cache=1024
  • Start MIST

Now it works. Maybe it just needed a restart, maybe I got lucky or maybe it was the cache parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.