1

I am working with Parity private network. I can manually add peers for each node and it works. But the problem is Bootnode executable from geth not working with Parity.

bootnode.exe -nodekey=key.txt -verbosity 9 -addr 127.0.0.1:30308

In parity config.tomal bootnodes = ["enode://6d5fe9514018fd79cb4ba13ce1182ebc2e470fc19efd4a06d718c210a82559c88423a4ea841833bb00d1da23bc2b26425c415863b5bd776f8b3eb5dbc81d5bed@127.0.0.1:30308"]

Hit is coming to bootnode but It can't recognize parity nodes.

Output: TRACE[06-06|20:22:51] << FINDNODE/v4 addr=127.0.0.1:30307 err="unknown node" TRACE[06-06|20:22:54] << FINDNODE/v4 addr=127.0.0.1:30305 err="unknown node" TRACE[06-06|20:23:00] << FINDNODE/v4 addr=127.0.0.1:30306 err="unknown node"

I have tried with -v5 also, no success.

What is the problem here?

0

Parity v1.11.3 seems to be solved this problem. https://github.com/paritytech/parity/releases/tag/v1.11.3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.