0

Today the block sync with Ropsten network on my machine is giving me following error :-

ERROR[06-05|06:59:12]
########## BAD BLOCK #########
Chain config: {ChainID: 3 Homestead: 0 DAO: <nil> DAOSupport: true EIP150: 0 EIP155: 10 EIP158: 10 Byzantium: 1700000 Engine: ethash}

Number: 3376467
Hash: 0x64b63b97eb45e2e1c31636e9ad7aef3941f393a27dfdca409952992a7e0db60c


Error: invalid chain id for signer
##############################

What could be causing this error ? How can it be resolved?

5
  • There's a bug report github.com/ethereum/go-ethereum/issues/16884 about it.
    – Ismael
    Jun 5 '18 at 13:22
  • But the issue still continues. I am still getting errors when syncing
    – Webdev
    Jun 6 '18 at 6:28
  • It seems to be a bug in parity client consensus rules, it will continue to happen until all parity nodes are upgraded. If you are using the most recent version of geth you should not worry it will behave as expected and reject the erroneous transaction.
    – Ismael
    Jun 6 '18 at 12:00
  • The version of geth installed on my machine is 1.7.3-stable . Do I need to upgrade ?
    – Webdev
    Jun 6 '18 at 12:50
  • The latest version of geth is 1.8.10, I think 1.7.3 is compatible with 1.8.xx but you should check with their release announcement if it is recommend to upgrade.
    – Ismael
    Jun 6 '18 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.