1

I am trying to use this - https://github.com/ethereum/wiki/wiki/Network-Status

I get that installed and it seems to run but nothing shows in localhost. I get this nothing in the http://localhost:3000 display. The cli output is shown below. What is the cause and how should I correct it?

Applying action restartProcessId on app [node-app](ids: 0) [PM2] node-app ✓ ┌──────────┬────┬──────┬───────┬────────┬─────────┬────────┬─────┬───────────┬─────────────┬──────────┐ │ App name │ id │ mode │ pid │ status │ restart │ uptime │ cpu │ mem │ user │ watching │ ├──────────┼────┼──────┼───────┼────────┼─────────┼────────┼─────┼───────────┼─────────────┼──────────┤ │ node-app │ 0 │ fork │ 23492 │ online │ 9 │ 0s │ 0% │ 13.4 MB │ satoshimaca │ disabled

I also get the logs working and the connection is established so the present issue is accessing the logs via a UI, eg http://localhost:3000

Here are the logs -

0|node-app | 2018-05-29 09:26 +00:00: [eth] =i= Starting web3 connection 0|node-app | 2018-05-29 09:26 +00:00: [eth] =✓= Web3 connection established 0|node-app | 2018-05-29 09:26 +00:00: [eth] ==> Getting info 0|node-app | 2018-05-29 09:26 +00:00: [eth] =i= { name: 'parity0', 0|node-app | contact: 'Trevor', 0|node-app | coinbase: '0x00bd138abd70e2f00903268f3db08f2d25677c9e', 0|node-app | node: 'Parity//v1.11.1-beta-6654d02-20180515/x86_64-linux-gnu/rustc1.25.0', 0|node-app | net: '8995', 0|node-app | protocol: 63, 0|node-app | api: '0.15.3', 0|node-app | port: '30300', 0|node-app | os: 'linux', 0|node-app | os_v: '4.13.0-1017-gcp', 0|node-app |
client: '0.1.1', 0|node-app | canUpdateHistory: true } 0|node-app | 2018-05-29 09:26 +00:00: [wsc] =i= Starting socket connection 0|node-app | 2018-05-29 09:26 +00:00: [eth] =✓= Installed chain filter 0|node-app | 2018-05-29 09:26 +00:00: [eth] =✓= Installed pending filter 0|node-app | 2018-05-29 09:26 +00:00: [wsc] =i= The socket connection has been opened. 0|node-app | 2018-05-29 09:26 +00:00: [eth] Trying to login 0|node-app | 2018-05-29 09:26 +00:00: [wsc] =✓= The socket connection has been established. 0|node-app | 2018-05-29 09:26 +00:00: [eth] =i= { id: 'parity0', 0|node-app |
stats: 0|node-app | { active: true, 0|node-app | syncing: false, 0|node-app | mining: false, 0|node-app | hashrate: 0, 0|node-app | peers: 1, 0|node-app | gasPrice: '0', 0|node-app | uptime: 100 } }

1

This works with eth-netstats I found. If you use

  1. npm start in eth-netstats the eth-net-intelligence-api product does run.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.