0

[{ "difficulty" : "0x20000", "extraData" : "", "gasLimit" : "0x8000000", "alloc": {}, "config": { "chainId": 15, "homesteadBlock": 0, "eip155Block": 0, "eip158Block": 0 } }]

this is my genesis.json file & as mention chainid is 15.

enter image description here

1

You are missing double dash in front of the datadir parameter. It should be geth --datadir=<YOUR_DATA_DIR> console. So you are reading from other directory.

You have to use the same --datadir when creating your private blockchain with geth --datadir=<YOUR_DATA_DIR> init <YOUR_GENESIS_FILE>.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.