0

Created a virtualenv with python3.6 and performed the following steps

git clone https://github.com/ethereum/vyper.git
cd vyper
make

I see following error(s):

Downloading https://files.pythonhosted.org/packages/e0/7b/9302e33972c4af861f5a425cb37468b4dbb17d7a4d282a657bfdb240055e/plyvel-1.0.4.tar.gz#sha256=134e78519403a6f71f1e66df945763413c48d0f6dec02e1a61f55adf0f83106d
Best match: plyvel 1.0.4
Processing plyvel-1.0.4.tar.gz
Writing /tmp/easy_install-hqyngt9f/plyvel-1.0.4/setup.cfg
Running plyvel-1.0.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-hqyngt9f/plyvel-1.0.4/egg-dist-tmp-hpr0sci6
warning: no files found matching 'plyvel/*.pxi'
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
plyvel/_plyvel.cpp:547:24: fatal error: leveldb/db.h: No such file or directory
compilation terminated.
error: Setup script exited with error: command 'gcc' failed with exit status 1
Makefile:4: recipe for target 'init' failed
make: *** [init] Error 1
0

Have you installed all the dependencies correctly ? You may also be missing CFLAGS and LDFLAGS variables (You have not mentioned the platform)

I wrote this blog post based on my experience. See if it helps.

There is also a link to this troubleshooting document (referenced from my blog as well.)

  • Thanks @mandarvaze will review the link that you shared and will update if it fixes. – ponarunkumar May 19 '18 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.