0

Hello i'm currently I have my chain running inside my virtual machine (with Ubuntu 16.04) and my PC (running Windows 10). NodeJS is running a server which i can access from http://192.168.0.108:3000/. metamask on PC Metamask running on firefox inside the VM can actually connect to the network.metamsk running on VM Have tried what this post suggests( MetaMask and Access Ethereum Private Chain from other PC in the same network (for test) ) but had no luck so far. This is my starting node commandgeth --datadir ~/eth-dev/ --identity 'nodo maquina local' --verbosity 4 --ipcdisable --rpc --port 30304 --rpccorsdomain "*" --nodiscover --syncmode "full" --networkid 7051872 --targetgaslimit 16233158 console

  • check if the 8545 is open in your vm or map it – Badr Bellaj May 9 '18 at 18:28
  • i have opened it using 'sudo ufw allow 22', but still not working – Roberto C. May 10 '18 at 5:11
  • i mean, 'sudo ufw allow 8545' – Roberto C. May 10 '18 at 16:25
  • try to explecite the port using -rpcport or use another port than 8545 – Badr Bellaj May 10 '18 at 16:29
  • i have tried setting it to port 7373 and the issue persists, metamask inside VM can connect but my PC cannot – Roberto C. May 10 '18 at 16:58
0

Open virtualbox -> right click on your machine -> settings -> Network -> Enable network adapter -> select bridge adapter and you can now set a port forwarder from your virtualmachine to your localhost.

Then, try to connect to http://localhost:8545 and that should work like a charm.

  • The only way i can configure port forwarding is with NAT adapter and that is no the conf i want to use. – Roberto C. May 10 '18 at 5:12
  • Which conf do you want to use then? – oktapodia May 10 '18 at 8:56
  • I'd like to stay on bridged mode – Roberto C. May 10 '18 at 16:16
  • since VM node is connected to other nodes running on AWS – Roberto C. May 10 '18 at 16:24
0

Force the port 8545 to rpc, e.g.

geth --datadir ~/eth-dev/ --identity 'nodo maquina local' --verbosity 4 --ipcdisable --rpc --rpcport "8545" --rpccorsdomain "*" --nodiscover --syncmode "full" --networkid 7051872 --targetgaslimit 16233158 console

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.