0

I'm just getting started with this. I started by reading this collection of articles:

https://medium.com/m/global-identity?redirectUrl=https://hackernoon.com/heres-how-i-built-a-private-blockchain-network-and-you-can-too-62ca7db556c0

The syntax they suggested for creating a private blockchain didn't work so I tried every combination I could think of. Eventually I tried the following:

geth init CustomGenesis.json --datadir .ACPrivateChain

Here's how I configured my install:

  • I installed geth in c:\program files\geth.
  • I created a genesis.json file and put it in this folder.
  • I created a subfolder named 'ACPrivateChain'.

When I run the command, I get:

"Fatal: invalid genesis file: invalid character '/' looking for beginning of object key string"

Can someone help with the right syntax for Windows?

thanks, clem

  • We'll need to see your genesis file... :) – Richard Horrocks May 8 '18 at 5:36
  • I just used the one from the tutorial: { "config": { "chainId": 987, "homesteadBlock": 0, "eip155Block": 0, "eip158Block": 0 }, "difficulty": "0x400", "gasLimit": "0x8000000", //set this really high for testing "alloc": {} } } – user3718738 May 10 '18 at 19:13
0

Remove the following block from your genesis file and try again!

//set this really high for testing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.