0

I have trouble syncing to Ropsten. I have just upgraded geth version to 1.8.7, then i run the command to remove the old chain: geth --testnet removedb. Then the command:

geth --testnet --syncmode "fast" --rpc --rpcapi="db,eth,net,web3,personal,web3" --rpcaddr="localhost" --rpcport="8545" --rpccorsdomain="http://localhost:3000" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@52.169.14.227:30303,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@13.84.180.240:30303"

but it stucks for hours at

"INFO [05-05|02:07:10] Mapped network port                      proto=tcp extport=30303 intport=30303 interface="UPNP IGDv1-IP1".

Can anyone please help me out?

Re-edit: After @Ismael proposal to remove the bootnodes, geth started running. Eventually it synced to Ropsten after the fork

  • Did you try syncing without passing the bootnodes parameters (so geth uses the default ones)? – Ismael May 5 '18 at 6:25
  • @Ismael when i run geth --testnet it start running. But will it sync to Ropsten after the fork? – kathi May 5 '18 at 7:01
  • If you use the last version it should, since v1.8.0 bootnodes were updated and should point to the correct fork. – Ismael May 5 '18 at 7:42
  • @Ismael ok thank you! i will let it running and then i will tell you if i managed to sync – kathi May 5 '18 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.