0

I am creating a local geth node participating in Ropsten to test my smart contract with other smart contracts such as ENS and Oraclize.

Somehow I keep running into problem of geth crashing and losing all the synchronised data.

The stacktrace of the crash is too long to post it here. So I will just post the beginning and end of the crash. enter image description here ... enter image description here

This is the truffle console output when I run eth.isSyncing() last night before I go to bed and this morning. enter image description here

In the background, I also ran command to deploy my smart contract to the local ropsten geth node. When I ran command last night, it sort of hang there and I assume it is because my local geth is not in-sync thus it is queuing and will be completed when the node is in-sync. Here is the screenshot. enter image description here

The command I used to start geth is as follows: geth --mine --testnet --datadir "~/github/ethereum_r/hello_world/testnet_data" --rpc --rpcapi eth,net,web3,personal --etherbase 0 --unlock 0 --password ~/github/ethereum_r/hello_world/password

I noticed Ropsten network is mining block at a rate of about 1 block per minute. I am wondering is that the reason why my node crash.

I turned on the mining so that I can observe my transaction being mined and confirmed. Is it required? I am suspecting perhaps it the mining that causes the crash.

  • How much memory does your instance have? I'd recommend at least 4 Gb, or at least enable swap. You will no be able to create transaction with your node until it has finished syncing. The frequency of the transactions is about 1 block each 15 seconds. If you cannot sync you might want to try using a public node from infure.io. – Ismael Apr 26 '18 at 19:32
  • It is running on my MacBook Pro with 16GB RAM. I didn't throttle CPU or limit memory. For public node like Infura, it seems there is throttling and limited around making synchronous call. Do you know if there is any paid service node that doesn't have limitation or another service provider beside Infura? – Thomas Apr 27 '18 at 5:44
  • With your machine specs should be enough to run geth. Are you using a HDD? Geth does not sync with them currently. Also syncing mainnet on a SSD can take a full day. – Ismael Apr 27 '18 at 16:21
  • Yes, I am using an external HDD. Let me switch to the built-in SSD and give it a try. – Thomas Apr 28 '18 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.