1

I am trying to import web3swift into one of my Swift files, but get the compiler error "No such module 'web3swift'". The import statements look like this:

"Import Geth" "Import web3swift"

In my pod file, I have:

pod 'web3swift', :git => 'https://github.com/MercuryProtocol/web3.swift.git', :branch => 'master'

I have also tried the following fix which hasn't worked: => In case you get no such module web3swift error Go to “Build Settings” Search “Framework Search Paths” (case sensitive) Double click on Click the “+” Add $(SRCROOT) and set it to recursive

  • Do you need any help with that? it should work fine now. – skywinder Jun 13 at 6:49
0

See this blog, In this blog, I have generated wallet as well as a transaction in Ether and ERC20 token.

https://medium.com/@shivangpandey195/getting-started-with-web3swift-1a2454481f70

0

As I can see you are importing MercuryProtocol repo: Web3.swift. And try to import Materinc implementation: web3swift

I recommend you to use this line in your Podfile:

pod 'web3swift'

https://github.com/matterinc/web3swift library is well supported and do all interactions natively without 3-rd party integration (like Geth in MercuryProtocol).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.