1

I am testing a private network for last few weeks. The block height has reached around 2,81,000 and now suddenly the memory usage of my server instance has shooted up TOO High and the geth process gets killed immediately after the 8GB memory is exhausted.

To resolve this I created a 100GB swapfile on the server and all the memory was exhausted and then again the process was killed, saying "out of memory".

Once I start geth (private chain with network id xxxxx), even when mining is stopped the memory usage starts to grow at 100mb/sec eating up all the RAM and the Swapfile

UPDATE

After researching for around 12 hours, An important thing is detected that it occurs only when I open the rpc port 8546, If start geth on any other rpc port, geth is satisfied with approx 550 MB RAM.

IS IT A DoS Attack?

7
  • are you using Proof of Work in your network? and do you need to do so for any particular reason or could you swap to a less computationally-expensive option such as Clique?
    – TC8
    Commented Apr 12, 2018 at 20:07
  • can you suggest how? and I am sure there is something wrong with my system as I know it will use up whatever amount of memory is given Commented Apr 13, 2018 at 0:33
  • What're you setting geths cache too? Try forcing a limit say --cache=4192
    – hextet
    Commented Apr 13, 2018 at 0:52
  • I am not explicitly setting geth 's cache. Setting --cache 4192, or even 2048, I tried every option but does not help. However please also check my update in the question. Commented Apr 13, 2018 at 1:04
  • have you fiddled with the parameters in the block-difficulty calculation?
    – Theo Port
    Commented Apr 13, 2018 at 9:41

1 Answer 1

0

If it happened to you as well, The probability is that you are opening your port on http://0.0.0.0.

Instead while running geth, use --rpcaddr as 'localhost'. or open your http endpoint on 127.0.0.1.

2
  • what is the effect for you after using this solution? thanks
    – Rafid
    Commented Dec 29, 2019 at 17:26
  • the effect was that the problem was solved. @Rafid. Please give me updates about could you solve this issue ? in case you are still facing it after changing the endpoint to 127.0.0.1, please let me know. Commented Dec 30, 2019 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.