Working on this blog

Tried to initialize bootnode throws and error


5 Answers 5


Probably you have already got the answer but since this thread is answerless. So here is your answer.

It was a bug in ethereum ci package (check here) and you can install bootnode with following command.

sudo add-apt-repository -y ppa:ethereum/ethereum
sudo apt-get update
sudo apt-get install bootnode

Part of the help command

  --bootnodes value     Comma separated enode URLs for P2P discovery bootstrap (set v4+v5 instead for light servers)
  --bootnodesv4 value   Comma separated enode URLs for P2P v4 discovery bootstrap (light server, full nodes)
  --bootnodesv5 value   Comma separated enode URLs for P2P v5 discovery bootstrap (light server, light nodes)

You should be able to run like in the example here


geth --bootnodes enode://pubkey1@ip1:port1,enode://pubkey2@ip2:port2,enode://pubkey3@ip3:port3

You can find the commands in sequence here:


The bash file won't work but you can copy paste the commands :).


geth --datadir node1/ init genesis.json
geth --datadir node2/ init genesis.json

bootnode -nodekey boot.key -verbosity 9 -addr :30310

geth --datadir node1/ --syncmode 'full' --port 30321 --rpc --rpcaddr 'localhost' --rpcport 8501 --rpcapi 'personal,db,eth,net,web3,txpool,miner' --bootnodes 'enode://cfb21bfd52f947041e020dfac76e51b6c466254053335b1e46107c0bbb1235e654a2fe10a2a23042437120d4233c3475d87e69db308c507c61f98bdc40d07720@' --networkid 999 --gasprice '0' -unlock '0xbba513f6e464e9f7d0c08125621e92598b1c28d6' --password node1/password.txt --mine
geth --datadir node2/ --syncmode 'full' --port 30322 --rpc --rpcaddr 'localhost' --rpcport 8502 --rpcapi 'personal,db,eth,net,web3,txpool,miner' --bootnodes 'enode://cfb21bfd52f947041e020dfac76e51b6c466254053335b1e46107c0bbb1235e654a2fe10a2a23042437120d4233c3475d87e69db308c507c61f98bdc40d07720@' --networkid 999 --gasprice '0' -unlock '0xaed59d65d7e4464d15999978b745f4ed9169b52a' --password node2/password.txt --mine
  • Link you share does not open.
    – alper
    Oct 8, 2018 at 12:23

It may be that development tools for geth was not added during the install process, click on the install file again and select the development tools:

enter image description here

After doing this bootnode worked.

Following tutorial: https://github.com/ConsenSys-Academy/geth-poa-tutorial

Hint to solution at: https://ethereum.stackexchange.com/a/12504/56328


From here: https://geth.ethereum.org/downloads download Geth & Tools, which include bootnode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.