4

Right after unboxing Drizzle-box I'm getting a TypeError: (0 , _drizzle.generateContractsInitialState) is not a function.

Ganache is running on localhost:8545, contracts are deployed, Metamask connected to localhost:8545, as it should. What I did wrong? Please help!

  • I'm having the same problem – am17torres Mar 29 '18 at 1:59
3

You'll need to bump the version of drizzle in package.json. If you do npm list drizzle you might be on 1.0.1. I did npm upgrade drizzle and 1.1.0 fixed the issue.

Now I have new issues :-\

| improve this answer | |
  • I've checked - I have drizzle@1.1.0 :-(. – Dmitry Pasenko Mar 29 '18 at 10:09
  • I got the issue stated in the question and after carrying out this step I am now getting the issue as reported here: github.com/truffle-box/drizzle-box/issues/15 – Calum Mar 31 '18 at 15:39
  • @am17torres What is your new issue? – Calum Mar 31 '18 at 15:46
  • I fixed my issue by changing my Metamask network to: localhost:8545. – Calum Mar 31 '18 at 15:47
  • @Calum - It's just stuck "Loading dapp...". The console says "Cannot read property 'address' of undefined." I have metamask connected to localhost 8545. My account id matches the first account id printed from ganache-cli -b 3 – am17torres Mar 31 '18 at 22:54
2

I had to update, drizzle-react & drizzle-react-component to 1.1.0

npm i drizzle-react@1.1.0 drizzle-react-component@1.1.0

seems to be working fine after doing so.

| improve this answer | |
  • you got a typo: it's drizzle-react-components (s at the end) – Florian Blum Apr 25 '18 at 6:51
0

this error is caused by drizzle package so to get rid of this error i've compiled the box myself :

git clone https://github.com/truffle-box/drizzle-box.git

then i've edited the package.json file to change the drizzle version:

 "drizzle": "1.1.5",

then

  • npm install

  • truffle compile

  • truffle migrate
  • npm run start

NB : There is a patch for this issue : check this pull request https://github.com/trufflesuite/drizzle/pull/95

Here's my package.json file :

  "dependencies": {

    "drizzle": "1.1.5",

    "drizzle-react": "1.1.1",

    "drizzle-react-components": "^1.1.0",

    "react": "^16.4.1",

    "react-dom": "^16.4.1",

    "react-scripts": "1.1.4",

    "redux": "^4.0.0",

    "eth-block-tracker-es5": "^2.3.2",

    "web3": "1.0.0-beta.34",

    "eth-block-tracker-es5": "^2.3.2",

    "react-redux": "^5.0.2",

    "react-router": "^3.0.2",

    "react-router-redux": "^4.0.7",

    "redux-auth-wrapper": "^1.0.0",

    "redux-saga": "^0.15.3",

    "redux-thunk": "^2.2.0"



  }
| improve this answer | |
0

Update several libraries by doing the following:

  1. npm update drizzle
  2. npm update drizzle-react
  3. npm update drizzle-react-components

Then: truffle compile, truffle migrate, npm run start

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.