4

I just started mining and everything seems fine but I don't know how to link my current geth account to a wallet. I've tried this:

How to import a plain private key into geth or Mist? and it looked like it worked but there isn't any ether on it.

  • Has Mist finished syncing the blockchain? Your Ether won't show up until it has. – Richard Horrocks May 26 '16 at 19:17
  • 3
    Possible duplicate of Sent ETH to my Mist Wallet, but it did not show up – Richard Horrocks May 26 '16 at 19:19
  • instead of trying to sync a wallet to my account should i just do a transaction and send my ether to my wallet through geth? And Ive been mining for about a day now, is it normal that when i check my balance it says i have 90ether ? – Vakaris Klyvis May 28 '16 at 13:19
  • When you import an "account" into a wallet, you're basically just importing the private key. There's no knowledge of how much Ether is in the account - that data comes from the blockchain. So for the Ether to show up, Mist has to download the blockchain data. Can you confirm if Mist has done that or not? (Once Mist is open it should show the latest block it knows about at the top of the screen.) – Richard Horrocks May 28 '16 at 13:27
  • Im pretty sure it has but the account that is linked to my wallet has 0 ether in it and all of my ether is in the account that i started with. – Vakaris Klyvis May 29 '16 at 14:40
1

Have you tried --etherbase "0x00000"

e.g. in your shell script: geth --rpc --rpcaddr "" --etherbase "0xa073edbcac4a489c3c0f71ec50dd6ffcefa49a00"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.