I have ropsten network running in localhost using command :

geth --testnet --syncmode "fast" --rpc --rpcapi db,eth,net,web3,personal --cache=1024  --rpcport 8545 --rpcaddr --rpccorsdomain "*" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@,enode://94c15d1b9e2fe7ce56e458b9a3b672ef11894ddedd0c6f247e0f1d3487f52b66208fb4aeb8179fce6e3a749ea93ed147c37976d67af557508d199d9594c35f09@" --verbosity=6

I can see its getting synced.But when I opened geth console:

 instance: Geth/v1.7.3-stable-4bb3c89d/linux-amd64/go1.9
 at block: 0 (Thu, 01 Jan 1970 05:30:00 IST)
 modules: admin:1.0 debug:1.0 eth:1.0 miner:1.0 net:1.0 personal:1.0 rpc:1.0 txpool:1.0 web3:1.0

at block is not updated. By passing command eth.syncing

  currentBlock: 2864241,
  highestBlock: 2864363,
  knownStates: 9349,
  pulledStates: 688,
 startingBlock: 2864149

currentblock was incrementing then it got stuck,then after running the first command again currentblock in geth console increments and stucks. But in geth testnet terminal syncing is continued just its not updated in geth console.

  • The main problem is about syncing, eth being not visible is an outcome of the same poblem. – Ayushya Mar 19 '18 at 6:45
  • But in the first terminal passing geth testnet, I can see DEBUG[03-19|12:18:58] Fetching batch of state data id=597740ce99926a90 conn=inbound count=2 DEBUG[03-19|12:18:58] Peer discarded announcement peer=2c7bcfec8f6fca6a number=2864444 hash=a1f24e…970159 distance=2864444 here block number is updated and I'm also getting imported entries INFO [03-19|12:21:44] Imported new state entries count=806 elapsed=8.085ms processed=384811 pending=5843 retry=4 duplicate=713 unexpected=1190 – angelmaria Mar 19 '18 at 6:50

"At block" should be the one getting updated. As you can see that there are many duplicates and unexpected blocks. These are coming from reorgs and peers sending the same blocks.

You may try following things:

  • restarting geth.
  • Enable network time synchronization using timedatectl set-ntp true and restarting geth.

Currently there is an open issue regarding syncing problems and there is another related question here.

  • I checked timedatectl status and its already enabled..I'll try by restarting geth.. – angelmaria Mar 19 '18 at 9:28
  • Guess all I need is to wait until 'known states' gets to 20-25 millions. – angelmaria Mar 22 '18 at 3:08
  • It is recommended to have a SSD instead of HDD. However, if you are unable to sync with geth, you may try using parity – Ayushya Mar 22 '18 at 3:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.