1

Apparently my installation of Geth breaks after some day of working, and log is not clear to me:

WARN [03-16|12:50:49] Synchronisation failed, retrying         err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:50:59] Node data write error                    err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:50:59] Synchronisation failed, retrying         err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:09] Node data write error                    err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:09] Synchronisation failed, retrying         err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:19] Node data write error                    err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:19] Synchronisation failed, retrying         err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
INFO [03-16|12:51:30] Imported new block headers               count=7    elapsed=36.176ms  number=5265382 hash=002ec2…b4af02 ignored=166
WARN [03-16|12:51:32] Node data write error                    err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:32] Rolled back headers                      count=7    header=5265382->5265375 fast=5265209->5265209 block=0->0
WARN [03-16|12:51:32] Synchronisation failed, retrying         err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:39] Node data write error                    err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:39] Synchronisation failed, retrying         err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:49] Node data write error                    err="state node 266e74…51868f failed with all peers (2 tries, 2 peers)"
WARN [03-16|12:51:49] Synchronisation failed, retrying 

I have no idea how to solve this. Furthermore, if I call

eth.syncing 

it returns false

But I dont receive any newBlocks event from websocket subscription.

1

Restarting geth must solve the problem, i also had same issue and after restarting it works like a charm

  • belive it or not, I tryed :) – Felice Pollano Mar 16 '18 at 13:13
  • may be your blockchain is upto date and there is nothing more to sync – shawn Mar 16 '18 at 13:16
  • so why no events? – Felice Pollano Mar 16 '18 at 13:19
  • if eth.syncing returns false, it means blockchain is fully synced. Try eth.blockNumber to check last synced block and match it with any explorer – shawn Mar 16 '18 at 14:08
  • canneven mean nor syncing at all as far as I know. eth.blockNumber is zero when using --fast – Felice Pollano Mar 16 '18 at 14:32
1

Update to go1.10 version and recreate your chain.

0

maybe too basic... but check your port is open. i run into that kinda issue quite often but generally restarting the geth resolves the problem, or just waiting and giving it another go later also works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.